アンサーインポート時に「すでにFAQが存在するカテゴリにサブカテゴリを作成することはできません」のエラーが出た場合の対処法
本記事では、PKSHA FAQ(旧OKBIZ)等の外部サービスを含め、アンサーカテゴリインポート時に「すでにFAQが存在するカテゴリ(ID: xxx)にサブカテゴリを作成することはできません」というエラーが出た際の原因と対策について記載します。
発生原因
本エラーは、文字通り「アンサーが存在しているカテゴリに子カテゴリを作成しようとした」場合に発生します。
RightSupportでは、カテゴリとアンサーに関する仕様として「カテゴリとアンサーは同じ階層に存在できない」というものがあります。
カテゴリ1の子カテゴリとしてカテゴリA, Bが存在する場合、カテゴリA, Bの兄弟要素として(同階層に)アンサーを作成することはできず、カテゴリA, Bの子要素として(下の階層に)しかアンサーを作成することができません。
これは既にアンサーが登録されているカテゴリについても同様であり、カテゴリ1の子要素としてアンサーが登録されている場合、カテゴリ1に子カテゴリを追加することはできません。
そのため、既にアンサーが登録されているカテゴリに対して子カテゴリ(サブカテゴリ)を作成しようとした場合、本エラーが発生します。
対処方法
本エラーはカテゴリとアンサーを同階層に存在させなければ発生しないため、「登録済みのアンサーを一度削除し、カテゴリインポート後に(子カテゴリの中に)再インポートを行う」といった方法で回避が可能です。
具体的には、
- 該当カテゴリのアンサーを全て削除する
- サブカテゴリをインポートする
- アンサーをサブカテゴリの中にインポートする
といった手順になります。
この際、削除されたアンサーのinternalIdは採番し直しとなるため、スラッグ機能を利用していない場合該当アンサーのURLが変わり、サイト内でリンクを貼っている場合リンク先がエラーとなってしまうためご注意ください。
サイト内で該当アンサーに対してリンクを貼っている場合、先ずスラッグ機能の設定を行ってから削除・インポートすることを推奨いたします。